Maxthon FR

Texte à méditer :  Sleon une édtue de l'Uvinertisé de Cmabridge, l'odrre des ltteers dnas un mot n'a pas d'ipmrotncae, la suele coshe ipmrotnate est que la pmeirère et la drenèire soeint à la bnnoe pclae. Le rstete peut êrte dnas un dsérorde ttoal et vuos puoevz tujoruos lrie snas porlbème. C'est prace que le creaveu hmauin ne lit pas chuaque ltetre elle-mmêe, mias le mot cmome un tuot.   

[RSS 2.0]

480-160805 1257-3633
480-160805 1257-3633:

Qui suis-je ?

Sites réalisés

Merci






Participez aux frais d'hébergement :

 
Liste des membres Membres : 258

Votre pseudo :

Mot de passe :

[ Mot de passe perdu ? ]


[ Devenir membre ]


  Membre en ligne :
  Anonymes en ligne : 12

Total visites Total visites: 1146554  

Record connectés :
Record connectés :Cumulé : 384

Le 03/08/2010 @ 11:53


Webmaster - Infos

Licences

Guppy

Guppy 4.5.x

Guppy plugins

mad AUCUN support par mail.
Utilisez le forum
biggrin pour signaler des bugs ou pour poser des questions.

forum.gifForum - GUPPY |= en générale - Sujet n°244

La Charte du Forum - La Charte du Forum

Forum - Forum
GUPPY |= en générale - GUPPY |= en générale


actif  Sujet n° 244  Erreur : fichier RSS non trouvé

le 04/02/2008 @ 13:30
par brachiop

Anonyme

visiteur

Bonjour, mon site ne peut pas récupérer les nouvelles des amis (RSS). J'utilise Guppy 4.6.5 avec RSS de base (pas de plugins). En cliquant sur les liens RSS mis sur une boite latérale, j'obtiens le message par exemple "Erreur : fichier RSS non trouvé... http://www.aldweb.com/data/nsfr.xml".
J'ai lu qq part que cela peut être dû  au fait que le serveur qui héberge le site ne permet pas la récupération des RSS, il est peut être question de la fonction include du PHP en externe ... Est ce que cela est vrai et comment y remédier ?
Merci d'avance et je vous souhaite bon courage.
Ecrire à brachiop   Poster une réponse  Haut

[]   

Réponse n° 1
--------
le 06/02/2008 @ 19:42
par hpsam



Administrateur
557 messages
Salut,
On avait déjà fait évolué en 4.5.? et c'est en 4.6.x.
Si l'inclusion de fichier externe ne fonctionne pas on utilise la librairie CURL normalement compilé par défaut avec PHP.

Regarde via le PHP info disponible dans le A propos de l'admin de GuppY  (Informations techniques> Environnement > PHP : 4.4.8 (Montrer les informations)).
  1. Pour curl, au début dans "Configure Command" tu dois avoir "--with-curl=".
  2. Pour l'ouverture direct : "Configuration PHP Core" > "allow_url_fopen" doit être à on.
Qu'en est-il ?
A+


Pas de problème sans solutions

Ecrire à hpsam   Site web hpsam Poster une réponse  Haut
Réponse n° 2
--------
le 07/02/2008 @ 11:41
par brachiop

Anonyme

visiteur
Bonjour Hpsam (king of RSS). Je vous remercie de votre réponse.
J'ai suivi vos consignes: Avec un phpinfo la directive "allow_url_fopen" est à on.
Pour la librairie CURL, elle est bien prise en charge, voilà ce que j'ai:
Dans "Configure Command" figure '--with-curl' mais pas d'= devant curl comme dans votre message ("--with-curl=")
En plus j'ai ceci :
curlCURL support enabled CURL Information libcurl/7.15.1 OpenSSL/0.9.8a zlib/1.2.3 libidn/0.6.2Par contre j'ai un message en rouge dans A propos de / Informations techniques / Version de GuppY
  • GuppY 4.6.5
  • La vérification de la mise à jour a échoué pour une raison inconnue.
PS.
- OS : Linux 2.6.15-1.2054_FC5smp (Fedora Core 5)
- PHP Version 5.1.6.
- Apache 2.2.0.
- GuppY 4.6.5
- URL site www.fsa.ac.ma

Merci d'avance.
Je reste à votre dispositon pour d'amples informations.
Cordialement.
Ecrire à brachiop   Poster une réponse  Haut
Réponse n° 3
--------
le 07/02/2008 @ 12:22
par hpsam



Administrateur
559 messages
Salut,
Le message en rouge est "normal" car c'est le même principe que pour le RSS. on récupère un fichier distant.
Par contre es-tu sur un serveur dédié, on dirait un problème de Firewall qui bloque l'accès sortant.
A+


Pas de problème sans solutions

Ecrire à hpsam   Site web hpsam Poster une réponse  Haut
Réponse n° 4
--------
le 07/02/2008 @ 20:57
par brachiop

Anonyme

visiteur
Bonjour,
Merci pour vos réponses.
Le firewall (iptables en occurence) laisse passer tous les paquets sortants.
Le serveur hébergeant GuppY ainsi que la passerelle de notre établissement sont sous mon administration.
Au fait, pour revenir à la lib CURL, n'est il pas génant de ne pas avoir le path précisé devant '--with-curl' de la configuration PHP ? Est ce que mon problème ne vient pas de là ?
Merci d'avance de vos suggestions et vos solutions.
Bien amicalement.
Ecrire à brachiop   Poster une réponse  Haut
Réponse n° 5
--------
le 14/02/2008 @ 23:43
par hpsam



Administrateur
563 messages
Salut,
Là je ne saurais te répondre. Je ne suis pas spécialiste des paramètresde compilation de PHP, ni de la configuration de serveur.

Mais tu peux faire un essai :
Modifie inc/LastRSS.inc
Trouve :
Code : php
                $timeout = 5; // set to zero for no timeout
curl_setopt ($curl, CURLOPT_CONNECTTIMEOUT, $timeout);
curl_setopt ($curl, CURLOPT_RETURNTRANSFER, 1);
$rss_content = curl_exec($curl);
curl_close($curl);
 
2 possibilités :
  1. une grosse lenteur réseau, alors test avec une valeur de $timeout à 0 pour l'annuler.
  2. rajoute une ligne pour afficher l'erreur cURL pour avoir plus d'information:
Code : php
                $timeout = 5; // set to zero for no timeout
curl_setopt ($curl, CURLOPT_CONNECTTIMEOUT, $timeout);
curl_setopt ($curl, CURLOPT_RETURNTRANSFER, 1);
$rss_content = curl_exec($curl);
echo 'ERREUR cURL : '.curl_error($curl);
curl_close($curl);
 A+


Pas de problème sans solutions

Ecrire à hpsam   Site web hpsam Poster une réponse  Haut
Réponse n° 6
--------
le 18/02/2008 @ 01:04
par brachiop

Anonyme

visiteur
Bonjour King of RSS

Merci pour le temps que vous avez consacré à répondre à ma question.
Mon problème est résolu. C'étais un paramètre de sécurité du serveur Linux qui bloquait les RSS : SELinux : Security-Enhanced Linux.
Il a fallu le mettre à Permissive pour qu'il laisse passer le trafic RSS.
La programmation des RSS dans GuppY n'était pas responsable donc pour ce genre de problème. Ce sera une piste à vérifier pour les GuppYstes qui se heurte à ce genre de problèmes.

Mille Merci encore une fois de plus.

Sujet Clos et problème résolu.
Ecrire à brachiop   Poster une réponse  Haut
Réponse n° 7
--------
le 18/02/2008 @ 08:57
par hpsam



Administrateur
564 messages
Salut,
Si tu peux me donner plus d'information (Distribution Linux, nom du paramètre...) sur ce paramètre.
Ainsi je le mettrais dans le lisezmoi.
Merci


Pas de problème sans solutions

Ecrire à hpsam   Site web hpsam Poster une réponse  Haut
Réponse n° 8
--------
le 18/02/2008 @ 15:55
par brachiop

Anonyme

visiteur
Bonjour King of RSS;
Distro : Fedora Core 5 (FC5)
Pour débloquer les RSS, il faut rendre SELinux "permissive".
(SELinux est présent sur la plupart des distributions Linux et mis à "enforcing" par défaut.)
ELinux (Security-enhanced Linux) doit être désactivé ou en mode"permissive".
Pour se faire,éditer le fichier /etc/selinux/config de façon à ce qu'il contienne SELINUX=permissive ou disabled et  redémarrer le système.

/etc/selinux/config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
SELINUX=enforcing
# SELINUXTYPE= can take one of these two values:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targetedJ'espère que j'étais assez claire et que ça profitera à certains guppystes.

Cordialement
Ecrire à brachiop   Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Cloturer Cloturer sujet   Remonter Remonter
[]
Catégories de discussion  Forum 


Avec Total RSS mettez du flux dans votre GuppY !

^ Haut ^